0

I run emacs on Windows and I start with this command:

C:\path-to\emacs.exe -q --load "C:/path-to-git-tracked-config-folder/.emacs" --debug-init

Emacs starts without error from --debug-init.

When I open a .org file the major mode is set correctly to org-mode.

But some essential settings are not applied untill I manually run M-x org-mode (font settings, hide the stars and activate org-bullets). Also the agenda is empty untill the manual run.

How can I track down the bug in my config responsible for this behaviour?

2
  • Do you mean: you start emacs as above with --debug-init, then open an Org mode file, the major mode is set correctly, but the initialization is incomplete? Then you do M-x org-mode in that buffer and the initialization is complete? Or do you mean something else? I can't quite understand the sequence of actions: can you please clarify?
    – NickD
    Jan 26 at 13:42
  • Yes exactly: 1. Start with --debug-init 2. open an org-file where org major mode is set correctly 3. Have to run M-x org-mode to see all the settings correctly applied. No errors from --debug-init. If I run M-x org-agenda before manually running M-x org-mode the agenda is empty. Only after running M-x org-mode manually (and a refresh of the persistent agenda) everything works as expected. Jan 26 at 16:49

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.