0

Running Doom Emacs 2.0.9 on Emacs 27.1.

In my init.el I have org-roam enabled like so:

:lang
(org +roam +journal)

In my config.el I also load org-habits, hide it in initial agenda view and set-up a keyboard binding like so:

(after! org
  (map! :map evil-org-agenda-mode-map
      :desc "Save all org buffers"
      :m "s s" 'org-save-all-org-buffers)
  (add-to-list 'org-modules 'org-habit)
  (setq org-habit-show-habits nil))

When I start emacs, at times (and very often) it shows all tasks that are habits as if they are normal tasks. Multiple restarts sets this right.

The keyboard binding is never available. I need to select the region and evaluate it to get the keybinding.

Lastly, org-roam auto-complete does not work reliably. At times, it does not work. Again, a restart (or several restarts) sets things right.

What could be the trouble? How can I ensure that everything works as expected right form the word go?

0

I've done something similar with evil-org-agenda, I think you want to run it after! evil-org-agenda (and not after! org) since that's where the key map is set (thus overriding your settings).

As for org-habit, try adding (require 'org-habit).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.