0

I'm trying to send mail using smtpmail through the protonmail bridge app. The protonmail-brdige runs a local smtp server with parameters:

  • 127.0.0.1
  • 1025
  • email
  • password
  • STARTTLS

The snippet I have in my smtpmail-multi-accounts

(protonmail . ("email@protonmail.com"
                        "127.0.0.1"
                        1025
                        "email@protonmail.com"
                        starttls
                        nil nil nil)

When trying to send the mail I got a popup stating that the ssl certificat offered by the host didn't match the hostname, which makes sense.

But after this I only get the following errors:

Sending...
Sending via mail...
Trying protonmail account... 
502 5.7.0 anonymous login not supported
221 2.0.0 Goodnight and good luck
Failed to send mail via protonmail account
smtpmail-multi-send-it: Mail not sent

I thought that the problem may be ssl. for offlineimap I had disabled ssl and this worked for mail retrieval. But I can't figure it out for sending.

Is there a way to disable ssl in smtpmail?

Or is the problem something else entirely?

Also where did the state of the authentication get saved ? as in I'm no longer receiving the ssl warning, but I'd like to reset things so I can look closer.

Thanks for any help!

6
  • 1
    (info "(emacs) Network Security") describes that. Look in "~/.emacs.d/network-security.data" – rpluim Feb 5 at 12:35
  • 1
    Also: have you set up ".authinfo" or ".authinfo.gpg" with the username and password to use? – rpluim Feb 5 at 12:37
  • Hi, yeah I filled out .authinfo with machine 127.0.01 login email@protonmail.com port 1025 password **** But the error seems to say I'm trying to log in anonymously, which doesn't seem to be the case – GreenLlama Feb 5 at 13:40
  • Thanks for the network-security.data tip. I was able to reset the connection this way and get it to prompt me about the certificate. But after accepting the security exception I end up with the same mail not sent error. – GreenLlama Feb 5 at 13:59
  • Ah I just saw there was a typo in the hostname in .authinfo. That seemed to do the trick... thanks for the help – GreenLlama Feb 5 at 14:31

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.