1

I have a early-init.el file with:

(add-to-list 'load-path "~/.emacs.d/el-get/el-get")

(unless (require 'el-get nil 'noerror)
  (require 'package)
  (add-to-list 'package-archives
               '("melpa" . "http://melpa.org/packages/"))
  (package-refresh-contents)
  (package-initialize)
  (package-install 'el-get)
  (require 'el-get))

(add-to-list 'el-get-recipe-path "~/.emacs.d/el-get-user/recipes")
(el-get 'sync)

If I don't put the last line (el-get 'sync)then I have no problem getting those commands Inserting Frequently Used Commands in a .texi file...

but, if I put (el-get 'sync) then C-c C-c runs the command TeX-command-master (found in Texinfo-mode-map), which is an autoloaded interactive compiled Lisp function in ‘tex-buf.el’ and I no longer have access to previous commands.

As I understand the problem comes from AUCTeX which includes a major mode for editting Texinfo files. This major mode is not the same mode as the native Texinfo mode of Emacs, although they have the same name.

How can I go back to Texinfo native mode ?

(Emacs Version 27.1 (9.0) on macOS BigSur Version 11.2)

3
  • Something in the rest of your config is loading auctex which redefines texinfo-mode. Feb 5, 2021 at 19:04
  • @FranBurstall It can't be that. I have renamed my init.el file to exclude it so the only config file loaded is early-init.el Feb 5, 2021 at 19:10
  • 1
    Is auctex mentioned in ~/.emacs.d/el-get-user/recipes? I can't remember how el-get works but it could be that the sync activates auctex which then overloads texinfo-mode. Feb 5, 2021 at 20:29

1 Answer 1

1

The solution is:

  • M-x customize-variable Customize variable: TeX-modes
  • uncheck texinfo-mode
  • State: Save for Future Sessions

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.