1

I've recently moved to spacemacs and it seems that they've adopted a different undo package (undo-tree) which I don't like since it does not push the undo actions back onto the history stack. I would like to restore the default behavior but I can't seem to figure out how to do this.

C-/ is bound to undo-tree-undo in spacemacs. I've tried to unbind this and use emacs' undo instead, but that does't seem to work. I've added the following in my user-config.el:

(global-unset-key (kbd "C-/"))
(global-set-key (kbd "C-/") 'undo)

But the key remains bound to the undo-tree method. I've also tried bind it to a new key, but the same seems to happen. It's as if spacemacs redirects call to for undo to undo-tree-undo. Is there anyway to fix this? Thank you.

EDIT

I've also tried adding undo-tree to the dotspacemacs-excluded-packages but it doesn't seem to get rid of it.

2
  • Have you tried to uninstall undo-tree? – Elia Feb 16 at 18:10
  • Can't uninstall it. I tried using package-list-packages and uninstalling it but it will not let me mark it for deletion. – oneself Feb 21 at 15:29
1

Well, turns out the solution is easier then I imagined. Just add the following to your user-config.el file:

(global-undo-tree-mode 0)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.