1

When I input a function, the R help document pops up automatically. It's very annoying. How to turn it off? screenshot

3
  • it doesn't do this by default. There is probably something in your configuration causing this problem. You could start by bisecting it to narrow down the likely problem: emacs.stackexchange.com/questions/28429/…
    – Tyler
    Mar 5 at 16:42
  • I use doom-emacs. It might be not easy to do that. Is this functionality provided by ESS? Mar 5 at 16:53
  • It's probably associated with ESS, but what you describe sounds very irritating - definitely not standard behaviour with ESS, which I also use extensively. I'm not familiar with Doom Emacs unfortunately
    – Tyler
    Mar 5 at 17:03
2

This is an interaction of company-mode with ESS. You can fix this issue like this:

(setq ess-use-company 'script-only)

This disables use of company-mode in the R terminal, but makes it available in R scripts. To disable it entirely in ESS, just use

(setq ess-use-company nil)

More useful information about company-mode with ESS can be found here:

https://www.emacswiki.org/emacs/ESS-company

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.