0

I have installed OpenSuse Tumbleweed and later Emacs.

If I start Emacs from the shell,

$ emacs -Q

I have a double row of menu entries

File - Edit - Options - ... - Help
New File - Open - Open Directory - ... - Search

In a sense, the buttons in the second row are not menus, because they directly invoke simple commands…

I'd like to get rid of the second menu row, maintaining the first one.

I checked the ~/.emacs that was automatically installed, apparently nothing relevant, and I've also tried emacs -q, to no avail.

8
  • Do you see the same problem if you start Emacs using emacs -Q - uppercase Q? (I don't.) If not, bisect your init file to find the culprit. If you do, then provide a step-by-step recipe, from emacs -Q, to reproduce the problem - as part of your question. Since you see this with emacs -q (lowercase), a guess is that it's caused by your site-wide init file, site-start.el - see Entering Emacs. If so, take up the problem with your site adminstrator.
    – Drew
    Mar 6 at 17:08
  • Which version of Emacs is this? Is it running in a terminal or with a graphic interface? I don't recall seeing this second menu row on any system. Mar 6 at 17:39
  • 1
    @Gilles'SO-stopbeingevil' It is Emacs 27, but it doesn't matter: it looks like it was not a real menubar but a text only toolbar, very similar to a menubar! See my self-answer below.
    – gboffi
    Mar 6 at 17:44
  • Please edit the question or the answer to make clear that the problem was misunderstanding that what looks like a second menu-bar row (which is entirely possible, BTW) is in reality in your case a tool-bar with textual tool-bar entries. This is clear from comments, but comments can be deleted at any time. Thx.
    – Drew
    Mar 6 at 20:40
  • 1
    I edited the title.
    – Drew
    Mar 8 at 4:17
1

Oops, what I mistakenly assumed to be a second menubar was indeed the toolbar in disguise! Here it is how I realized my mistake.


In OpenSuse, /usr/bin/emacs is a lengthy shell script that eventually starts either /usr/bin/emacs-gtk or /usr/bin/emacs-x11.

When I tried emacs-gtk -Q I had the same results as using the system script, so I tried also emacs-x11 -Q and Emacs opened a window with the menu and an iconic toolbar.

I had a moment of enlightenment noticing that the toolbar entries had a perfect match with the "menu" in the second row...

So I used Options → Toolbar → None and voila, the second row disappeared.

For some reason GTK rendered the toolbar buttons using text only, in a format that was virtually indistinguishable from the menu entries of the first row... and I needed to start emacs-x11 to be enlightened because I'm not used to using the toolbar.

0
0

You can add this to your .emacs:

(tool-bar-mode -1)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.