2

I am running Emacs 26.3 on MacOS 11.2.1 “Big Sur”. When I try to open the directory ~/Documents, it fails with the message “Listing directory failed but ‘access-file’ worked.” Emacs.app is given Full Disk Access in my System Preferences. I can open other directories, but not Documents, Downloads, or Desktop.

However, the problem does not occur if I start Emacs not by launching it from the Dock but by opening it from the Terminal with:

/Applications/Emacs.app/Contents/MacOS ./Emacs

Any ideas about why this is happening and how to fix it? If I launch it from the terminal I get a couple of error messages:

2021-03-07 16:49:59.308 Emacs-x86_64-10_14[5820:4969143] Failed to initialize color list unarchiver: Error Domain=NSCocoaErrorDomain Code=4864 "*** -[NSKeyedUnarchiver _initForReadingFromData:error:throwLegacyExceptions:]: non-keyed archive cannot be decoded by NSKeyedUnarchiver" UserInfo={NSDebugDescription=*** -[NSKeyedUnarchiver _initForReadingFromData:error:throwLegacyExceptions:]: non-keyed archive cannot be decoded by NSKeyedUnarchiver} 2021-03-07 16:50:24.499 Emacs-x86_64-10_14[5820:4969143] TSM AdjustCapsLockLEDForKeyTransitionHandling - _ISSetPhysicalKeyboardCapsLockLED Inhibit

but Emacs seems to work just fine.

My folders are not synched to the Cloud.

3
  • 1
    Are you running the Emacs from emacsformacosx.com? If you are, that version has both the Emacs app and also a ruby wrapper around Emacs, and you'll have to grant access to the ruby wrapper as described in this question. However, the error you're seeing is different from errors I've seen before so the ruby wrapper may be unrelated.
    – amitp
    Mar 8 at 0:49
  • I think you're saying that the access-denial occurs regardless of whether you use Dired, so I replace tag dired by tag directories. If it is truly Dired related then please add back tag dired. But in that case please say something in the question about the Dired relation. Thx.
    – Drew
    Mar 8 at 4:15
  • Thanks amitp. That solved the problem. First, I had to find ruby, but with a bit of detective work I was able to figure out that it was in /usr/bin/ Mar 8 at 21:37

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.