0

When you recursively copy a large remote directory through Tramp, it will ask for confirmation for large files. Because of that, you can't leave the copy in the background, since the confirmation pauses the copy. And the "large file" size is something ridiculous, like 10MB.

How do I disable this? It really slows down the copy process.

2
  • Explain how you're copying. You added tag dired, so perhaps you're using that? Please provide a more complete description/recipe for the problem. – Drew Mar 10 at 19:08
  • 1
    Also please add the exact message you get. – NickD Mar 10 at 19:46
1

This is controlled with large-file-warning-threshold variable.

Do C-h v large-file-warning-threshold RET.

Then hit customize.

Then hit Value Menu.

Then choose "Never request confirmation".

However, setting it globally affects more than just tramp copy (open large file, for instance). So you may wanna limit its usage with finer control.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.