0

I use Spacemacs and it is great. But for some reason, each time I save a file--usually an org file, Spacemacs will try and parse my default bibtex file. And that file is relatively large, so it adds a weird amount of time either when saving or even when auto-saving. I am not sure where to look to fix this.

I use helm-bibtex which is again, wonderful. But each time I save a file, in the Messages I see:

Saving file /home/.../myfile.org...
Wrote /home/.../myfile.org
Parsing bibliography file ~/Dropbox/.../library.bib ...
forward-sexp: Scan error: "Unbalanced parentheses", 2702612, 6340258

And on each save it seems to find some parsing errors--so the save is triggering a validation or parsing of this large bibtex file.

I was looking in the after-save-hook and before-save-hook variables, but I did not see anything that immediately caught my attention. Is there something that could be causing this, either in the helm-bibtex settings or somewhere?

Any help is really appreciated. Thanks.

2
  • Try with emacs -q to make sure that it does not happen without yuour init file. If indeed it does not happen, bisect your init file to find the culprit. – NickD Mar 10 at 20:41
  • @NickD good idea. I will give that a shot and see if I can find the source. Thanks for the suggestion. I have not fiddled with my config in a while, haha. – krishnab Mar 10 at 22:48

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.