2

I recently saw my emacs (GNU Emacs 27.1 running on Arch Linux) throw this error:

Error enabling Flyspell mode:
(Error: No word lists can be found for the language "en_US".)

when I visited a markdown file. My emacs is configured to use the latest commit on the develop branch of spacemacs. Any idea how I can allow Flyspell to find a word list?

I tried the solution from Error: No word lists can be found for the language "en_US", which was to simply install aspell, but it doesn't fix the problem.

3
  • Please don't post the same question to StackOverflow and emacs.SE. Please delete one of them. Thx.
    – Drew
    Mar 15, 2021 at 16:50
  • Sure. I've deleted the duplicate StackOverflow question. Mar 15, 2021 at 17:09
  • Thank you......
    – Drew
    Mar 15, 2021 at 17:29

1 Answer 1

5

One needs to install additional dictionaries used either by ispell or, in your case, aspell programs: there are corresponding packages for them (looks like this, I'm not on arch, so can not speak for this).

You can see what kind of languages are available using M-x spell-checking/change-dictionary.

1
  • None of these functions exists in my Emacs 26.1. Oct 17, 2021 at 6:54

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.