1

I installed rustic-mode with LSP server. They work. But now it shows docs and description of every symbol I put my cursor on. It distracts and irritates me a lot. How can I make it show the symbol info and docs on demand only when I click a certain key? I tried this:

(setq lsp-eldoc-render-all nil)
(setq lsp-enable-symbol-highlighting nil)
(setq lsp-eldoc-render-all nil)
(setq lsp-signature-render-documentation nil)

But only what I got so far is this:

enter image description here

3

Try the following.

(setq lsp-ui-doc-enable nil
      lsp-ui-sideline-enable nil)

You can check how to set/reset the options from the LSP page.

2
  • Do you know, what functions to call to get the docs / symbol info on demand?
    – user4035
    Mar 18 at 20:40
  • You can try lsp-ui-doc-mode and lsp-ui-doc-glance. Mar 20 at 16:25

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.