1

I am working on a Rmarkdown document and I have R 4.0.4 running in a buffer. I try to export the document with M-n e and it finds R 3.6.3

sessionInfo()

R version 3.6.3

This meant that I had a lot of trouble with packages not being found before I saw the underlying problem. I have a distribution R 3.6.3 in /usr/bin and a more recent R in /use/local/bin. poly-R may be using absolute path names but I can't see how to configure it.

1

Polymode uses ESS to interact with R. Your locally-installed version of R in /usr/local/bin is probably not on the exec path. You can configure this via the variable ess-rterm-version-paths. You may also need to check the values in ess-r-runner-prefixes to make sure it includes R-4.

These configurations have changed in the past few years, so it will be helpful to know which version of Emacs, ESS and polymode you are using, and also your OS.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.