1

I have been constantly trying to render a logo.svg found in my custom title-page (included in #LATEX:) to match our university title-page for academic writings, but have unfortunately not had success doing so. I have since yesterday been trying to render the .svg files included in my .org writing, but unfortunately arrived at no solution..

Note that the following list includes methods I have attempted in a doom-emacs enivronment to resolve the issue while having inkscape, libsvg and imagemagick installed on my system.

What I have tried by far:

  1. Used different formats (.png, .pdf and .svg), but failed to display any image through both \includegraphics and \includesvg. Keep arriving at: "cannot find file" and I do not know how to resolve this issue. I have tried to use both full/relative paths, but couldn't produce the desired output.

  2. .svg files located inside .org files are not exported through org-export even after including #+LATEX_HEADERS: \usepackage{svg}. I suspect that this could be the issue, but I am not certain.

  3. pdflatex -shell-escape file.tex returns the same issue as org-export does, which is the .svg images not being displayed.

Another issue that I am facing is paragraphs not being created for lines separated by a newline between them. Because of this, my text currently looks like one mash of text without any separation, which is in my opinion looking hideous.

If you know how to resolve this issue, please do help me since dropping emacs because of this is in my personal opinion not a wise choice. Not to mention that I am really comfortable in my doom-emacs environment and would prefer it over writing my academic work in google-docs. :/

3
  • The pastebin for both the template.texand the file.org can be found at: custom title-page and org-file – Icy-Thought Mar 30 at 21:02
  • The paragraph issue was resolved through #+OPTIONS: \n:t thanks to Ryan from the org-mode matrix server. Will update if I figure out how to configure paragraphs to adjust them to \begin{equation}. – Icy-Thought Mar 31 at 12:33
  • Removed \begin{figure} and \end{figure}, replaced includesvg{logo.svg} with \includesvg{src/logo.svg}and also included --shell-escape in org-mode config.el to fix this issue thanks to hpd from org-mode matrix server. – Icy-Thought Mar 31 at 14:12
1

Solution:

  1. Paragraph spacing: add #+OPTION: \n:t.
  2. Fix svg rendering issue: add --shell-escape to config.el (doom-emacs):
(setq org-latex-pdf-process
      '("pdflatex -shell-escape -interaction nonstopmode -output-directory %o %f"
        "pdflatex -shell-escape -interaction nonstopmode -output-directory %o %f"
        "pdflatex -shell-escape -interaction nonstopmode -output-directory %o %f"))
  1. Source logo.svg in file.org based on the relative path of logo.svg from file.org. In my case the relative path is src/logo.svg, which results in: \includesvg{src/logo.svg}

Appreciate the help both @ryan_c_scott and @hpd from org-mode matrix server have provided me and wish that this will be useful to someone else facing the same issue!

1
  • You can 'accept' your own answer, which helps us by removing your question from the 'unanswered' queue. – Tyler Apr 9 at 20:29

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.