0

Up until an hour ago I had a working installation of Emacs version 26.2 on my Late 2013 iMac running macOS Catalina version 10.15.7 (this is the latest version available for my computer). I would run Emacs from the terminal by cd-ing to a certain directory and then executing:

emacs

Everything was dandy until, yesterday, for no good reason, I decided it was time to update my Emacs to the latest version. This was especially asinine since I'm in the middle of writing my thesis and I'm already behind schedule. But I went along and tried to update it via Homebrew.

I described my failed attempt to update Emacs in this post that I posted yesterday to the apple stachexchange forum.

A certain user named nohillside suggested in the comments that I uninstall emacs, remove Emacs from the Applications directory, and then try to reinstall it. I followed this suggestion about an hour ago. Unfortunately, it didn't succeed in updating my Emacs installation. Worst: the command emacs no longer works at all.

Please help me get Emacs working again.

14
  • In your other question you show that emacs --version works, so it's not true that "the command emacs no longer works at all"? Or did you subsequently uninstall the working version?
    – phils
    Commented Apr 7, 2021 at 10:33
  • In any case, I think OSX users tend to use emacsforosx.com ? I'm not sure, but maybe try that if nothing else is working.
    – phils
    Commented Apr 7, 2021 at 10:35
  • @phils: I followed a suggestion made in the comments and uninstalled emacs and subsequently reinstalled it. It's all described in the other post.
    – Evan Aad
    Commented Apr 7, 2021 at 10:35
  • If you still have the version 27.2 installed, to start it from terminal type emacs-27.2 -Q and if this works, then you may try without -Q or just start bisecting your init file. I had the same problem when moving from 26.3 to 27.1, and solved by bisecting and removing a package.
    – Ian
    Commented Apr 7, 2021 at 10:56
  • @Ian: emacs-27.2 -Q doesn't work: zsh: command not found: emacs-27.2
    – Evan Aad
    Commented Apr 7, 2021 at 11:00

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Browse other questions tagged or ask your own question.