0

Emacs 26.3

CentOS 7.0

Install packages soap-client 3.2.0 and cl-lib 0.6

https://github.com/alex-hhh/emacs-soap-client

https://elpa.gnu.org/packages/cl-lib.html

In my init.el I add

   (require 'soap-client)

But after restart Emacs I get error:

Warning (package): Unnecessary call to ‘package-initialize’ in init file
Package cl is deprecated
1
  • 1
    I suspect you have another question behind what you actually asked. If so, ask it separately. See also What is the X-Y problem?. – Drew Apr 14 at 15:09
5
  1. Something that is deprecated is not unsupported. So it's not true that you cannot use it.

  2. A warning is not, at least in Emacs, an error. It's just a message to let you know something you might not otherwise be aware of. And many, many Emacs warnings are benign in actual use, for various reasons. You need to understand a warning, and do so in the context of what you're doing, in order to know whether you need to do something about it or not.

1

You're using Emacs 26, and the cl-lib version you're referring to is for Emacs 24. Use the built-in package manager: M-x list-packages.

  • Emacs 26 will probably have cl-lib 1.0 already installed.
  • The soap-client you're referring to in github is old (ie. not v3.2.0).
  • If you have older versions installed, un-install them.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.