1

After updating Emacs from 27.1 to 27.2 (current stable of Fedora 33 default repository), I found myself with the dilemma that once I open an ORG mode file, all subtrees and children thereafter are opened instead of neatly wrapped up and folded.

Is this an expected change for ORG mode? If it is, can one revert to start with a folded tree globally without having to add headers in each and every file one works on?

2

Ok. Found the culprit: org-startup-folded

According to the built-in help:

This variable was introduced, or its default value was changed, in
version 9.4 of the Org package that is part of Emacs 27.2.

While this answers the questions posed, it throws up another question as to why this was changed. However, since "why"-questions can be dug in indefinitely, I draw the line here after having changed the variable to the former reasonable state. It is even a built-in variable which can be customized through Emacs internal routines.

For those not too familiar, call up its help C-h v, then type in the above variable and press ENT. In the help you find a link to "customize" this variable.

5
  • 1
    It was done for the sake of beginners in Org mode: they were often surprised (and not in a pleasant way!) when they opened a file and found most of the contents seemingly gone. OTOH, it was thought that experienced people would know how to restore the behavior they preferred - which you seem to have done successfully! You can read about such changes in the etc/ORG-NEWS file that comes with the release, although the motivation for this change is not described in that file.
    – NickD
    Apr 25 at 14:24
  • BTW, you can accept your own answer to mark the question resolved.
    – NickD
    Apr 25 at 18:19
  • @NickD, Thanks! I was looking high and low for this ORG-NEWS link, but didn't find it. I should possibly bookmark it. :D
    – Phoenix
    Apr 25 at 18:23
  • 1
    About accepting my own answer: While I was aware, I somehow had in the back of my head that one needed to wait 24 hours or something after posting to be allowed to do so. So, I haven't actually tried before. After having tried now, however, I got the confirmation: The error message of StackExchange states "You can accept your own answer in 2 days".
    – Phoenix
    Apr 25 at 18:24
  • I forgot about the waiting period.
    – NickD
    Apr 26 at 12:22

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.