1

When programming in extended assembler (using asm-mode), auto indentation insists on indenting compiler directives, such as #define, #if and #endif, how can I disable this?

problem example

Emacs version: [email protected] (spacemacs)

1 Answer 1

1

setting electric-indent-mode to nil on asm-mode-hook resolved the issue.

1

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.