1

After upgrading to org-mode 9.4.4 when I create a simple org file with a list (though it could be a heading) like below:

- test

And hit return, then it automatically indents. This doesn't make any sense because there is no hierarchy. How can I disable this?

2 Answers 2

1

Set the variable org-adapt-indentation to nil by running the command M-x set-variable.

1
  • 1
    I have org-adapt-indentation set to nil, and it's still doing the behavior described. Per the org-mode FAQ the correct solution appears to be to disable electric indent for org-mode with a mode hook.
    – quanticle
    Jul 3, 2022 at 21:16
0

Why it does make sense:

plain list entry doesn't limit to single line. Below is legit list.

- In publishing and graphic design, Lorem ipsum is a
  placeholder text commonly used to demonstrate the
  visual form of a document or a typeface without
  relying on meaningful content.

How can I disable this?

Usually C-j and RET(or C-m) behave differently, one does indentation and the other doesn't. You may check it up and consider exchanging its bindings. (In my emacs RET bind to org-return and it doesn't indent by default)

1
  • I didn't see this as a counter-example to the question, as it shows the behavior of a long line, not a return. It does, indeed, make sense to me that a long line should wrap and be considered part of the "legit list." It does not make sense to me that a return should [usually/mostly/be assumed to] do the same.
    – Hendy
    Dec 29, 2023 at 18:23

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.