0

When I start emacs and run M-x up-list in the initial buffer (the about Emacs buffer, in fundamental mode) I get Scan error: "Unbalanced parentheses". If I move the mark to the end of the buffer, the error gives the character range 1057, 1057 Again, this is not really a buffer of parenthesized expressions, and there certainly aren't any dangling parens at the end.

I'm on an OSX machine, running emacs 27.2 I've tried starting emacs with -nw -Q --debug-init. I've tried the same experiment in another buffer. If I instead go to the initial scratch buffer, both M-x up-list or M-x down-list give the same error. I presume it's not just these two commands, these are the handful I used as tests.

I don't think it should matter, but (I believe) I've also moved and renamed my .emacs file and my .emacs.d directory, so neither of these should be relevant.

I've tried uninstalling and reinstalling emacs via Homebrew, and tried enabling both the standard emacs formula and the emacs-mac port.

Why is the reader saying my parens are unbalanced, and how do I resolve this? What could be causing this? I can M-x down-list into a set of parens, but editing around when the reader thinks my parens are unbalanced would be very annoying.

I still don't know the actual /cause/ or /explanation/ of the problem. But the workaround solution was to uninstall, to re-reinstall, and reboot my system. It would still be nice to know how I might have resolved this without needing to reinstall or reboot my system.

2
  • 2
    Cannot reproduce on emacs 28.0.50 Linux. up-list returns At top level – Juancho May 21 at 14:27
  • Right. So something's wrong locally, as I expected. To rephrase the question, @Juancho, what could still be wrong locally on my system? – Jason Hemann May 21 at 14:53

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.