1

CentOS 7, Emacs 27.1

Suppose I wan to to connect to the remote host (by ssh).

Approach#1 Opent Linux terminal and run the next command

ssh [email protected]

Type password and after about 3 seconds I success connected to the remote host. Nice.

Now I want do same by Emacs.

Approach#2

I use Tramp mode. I my bookmarks I already has link to remote host. So I only jump to bookmarks like this;

mybookmarskEntity  /ssh:[email protected]:/home/someLoginHome/

and wait ... about 30 seconds. And only after 30 seconds I success connected to the remote host.

Why so slowly?

3
  • 1
    Try without using the bookmarks to compare how it works.
    – prash
    May 25, 2021 at 14:41
  • 1
    @prash If use direct Find file (C-x C-f) "/ssh:[email protected]:/home/opencm/" then connect fast . About 3 seconds. May 25, 2021 at 15:10
  • 1
    You should profile bookmarks and see why there is such a large discrepancy. It might be caused by some setting of yours (that't the more likely scenario), but in the unlikely case that it is a problem with bookmarks, I'm sure the devs would appreciate a bug report.
    – NickD
    May 25, 2021 at 16:47

1 Answer 1

2

Very likely you run into a timeout. You could detect this, if you retry your test with tramp-verbose set to 10. If you ned assistance in reading Tramp's traces, contact us at ML[email protected] .

2
  • If use direct Find file (C-x C-f) "/ssh:[email protected]:/home/opencm/" then connect fast . About 3 seconds. Without bookmarks May 25, 2021 at 15:10
  • 1
    As already said, you must partly disable bookmarks until you find the guilty part. If you need assistance in debugging, pls contact us via the [email protected] ML. May 27, 2021 at 8:14

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.