0

When I run a bash code block I get a response which contains a lot of escape codes/sequences, which makes the results output less readable. Example below:

example code block output with escape codes/sequences

How can execute the code block, without the ugly escape codes being included?

3
  • You could treat it in bash by removing escape sequences (e.g. unix.stackexchange.com/questions/172000/… ) or treat it in Org using :post to cleanup the output. – mankoff Jun 6 at 14:59
  • 2
    See if terraform has an option to omit them. E.g ls has a --color=never option to avoid producing color codes. There also may exist an environment variable that controls this (e.g. LS_COLORS does this for ls). – NickD Jun 6 at 15:00
  • @NickD, thanks, that did the trick (at least for terraform), will figure out other solutions for other commands where this is happening – Hyperfocus Jun 7 at 8:45

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.