When I start up emacs, it prints Invalid face: highlight and then exits. This problem happened after I reinstalled Ubuntu 21.04 from scratch.

Any suggestions on how to debug this?

  • I have tried 26.2 from ubuntu... same problem.
  • I have tried downloading and compiling 27.2. Same problem.
  • I have tried commenting out every line in my .emacs file. Same problem.
  • emacs -q has the same problem.
  • emacs -q --debug-init has the same problem.
  • emacs -Q brings up an emacs window.
  • Is there a backtrace with --debug-init? If so, can you post it in some pastebin and link it here?
    – NickD
    Jun 16, 2021 at 18:19

2 Answers 2


If the problem persists with emacs -q, and not for emacs -Q, then the source is most likely in site-start.el. site-start.el is sometimes provided by distributions, and you might find it in /usr/local/share/emacs/site-lisp, /etc/emacs/.

On Ubuntu, running the command locate site-start.el from the command line might show you other locations.

Any files in the directory/etc/emacs/site-start.d/ may be involved too.


I narrowed the problem down to a file in /usr/local/share/emacs/site-lisp: subdirs.el.

It contains

(if (fboundp 'normal-top-level-add-subdirs-to-load-path)

instead of the following which is in the source for emacs 27.2:

;; In load-path, after this directory should come
;; certain of its subdirectories.  Here we specify them.
(normal-top-level-add-to-load-path '("vc" "url" "textmodes" "progmodes" "play" "org" "nxml" "net" "mh-e" "mail" "leim" "language" "international" "gnus" "eshell" "erc" "emulation" "emacs-lisp" "cedet" "calendar" "calc"  "obsolete"))
;; Local Variables:
;; version-control: never
;; no-byte-compile: t
;; no-update-autoloads: t
;; End:

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.