1

Emacs in this particular installation doesn't parse hyphens in Man-mode. I found the definition and initialization of Man-filter-list, but I don't really know what to do with it, as I cannot really see well the code being displayed incorrectly.

I think, this may also be related to the font not having the hyphen character. So, I'm not sure which direction to take this: try to look for a different font, or try to filter out the hyphens.

Would appreciate a snippet for filtering it out though, just in case.


I just tried changing font, it seems to be unrelated. Also, this appears in ansi-term in Emacs too, i.e. man pages render incorrectly around hyphens (the characters preceding hyphens appear to have a caret on top of them). This doesn't appear in other terminal emulators, like Gnome terminal. However, in XTerm man seems to run in a mode where it doesn't try to hyphenate words (it's slightly uglier, but no botched symbols).


OK, setting Man-switches to "--nh -E ascii" (for no hyphenation and no other weird characters) helps avoiding the botched characters, however, I'd love to know how to have hyphens and have them displayed properly.

1 Answer 1

1

OK, finally, I more or less figured out what the problem was.

Long story short, Emacs was running man with ISO Latin as its encoding system. However, man will still generate a bunch of special characters, hoping that the terminal will somehow interpret that, yet the terminal didn't know how to handle them.

So, one way was to tell man to not to generate strange characters, that is by setting Man-switches to --nh -E ascii.

Or, tell Emacs to deal with Unicode in Man pages by setting Man-coding-system to utf-8.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.