0

I successfully installed gnus with imap backend to access the outlook messaging service.

I could not make gnus access directly the exchange server by imap so, I settled davmail which acts as a local imap server and forwards gnus imap commands to something understandable for the exchange server.

Then, in outlook, I moved some old messages from one directory to the INBOX. When I opened again the INBOX from gnus, these old messages now appear at the top of the group summary as if they were the most recent. In order to get the most recent ones, I have to scroll down until the last old message. This does not happen in the outlook client.

In outlook, I moved some most recent INBOX messages on a temporary directory and then, moved them back to the INBOX. These most recent messages now appears correctly from gnus.

I am not sure it is a gnus bug. It seems that, when I move some messages in outlook from one directory to another, gnus sees them as newer than previous messages, most recent by date, in destination directory.

I displayed the whole header of some moved messages ... nothing unexpected, the dates are correct. How can I make gnus display messages correctly in that case ?

Regards

0

Gnus sorts the messages by their ID number as used by the IMAP protocol. Moving a message changes its ID number, so this behavior is expected. You can sort a summary buffer in a number of ways:

C-c C-s C-a     gnus-summary-sort-by-author
C-c C-s C-c     gnus-summary-sort-by-chars
C-c C-s C-d     gnus-summary-sort-by-date
C-c C-s TAB     gnus-summary-sort-by-score
C-c C-s C-l     gnus-summary-sort-by-lines
C-c C-s C-n     gnus-summary-sort-by-number
C-c C-s C-o     gnus-summary-sort-by-original
C-c C-s C-r     gnus-summary-sort-by-random
C-c C-s C-s     gnus-summary-sort-by-subject
C-c C-s C-t     gnus-summary-sort-by-recipient
0

Thanks for your answer.

Actually, I think the trouble happens before the summary display and how message are sorted. When I enter a group, I am asked how many messages I want to retrieve, because it is a large group. It seems gnus retrieves the first 200 messages according to their ID number, not the date.

Then, I can sort the summary buffer in any way I want, I still get the oldest messages because they were prefered, thanks to their ID number, upon retrieving them from the IMAP server (davmail/outlook exchange).

How can I modify the criteria according to which gnus retrieves messages from the server ? Setting this criteria to the most recent date would them solve my problem.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.