0

I have customized my org todo state keywords to the following:

(setq org-todo-keywords
  '((sequence "EVENTUALLY(e)" "BONUS" "OPTION(o)" "TODO(t)" "|" "DONE(d)" "CANCELLED(c)")
    (sequence "OPTIONAL_SPEC_BEHAVIOR" "REQUIRED_SPEC_BEHAVIOR(b)" "|" "IMPLEMENTED_SPEC_BEHAVIOR" "CANCELLED_SPEC_BEHAVIOR")
    (sequence "OPTIONAL_SPEC_COMPONENT" "REQUIRED_SPEC_COMPONENT(s)" "|" "IMPLEMENTED_SPEC_COMPONENT" "CANCELLED_SPEC_COMPONENT")
    (sequence "QUESTION(q)" "|" "ANSWERED(a)")
    (sequence "WORK_SESSION(w)" "|" "FINISHED_SESSION" "CANCELLED_SESSION")))

They have been working fine except that I just started using org-agenda and ran into the following issue:

When my cursor is on the line of a todo item and I hit "t", the minibuffer expands and shows a list of all the todo states that I can change to. However, since I have so many todo states, "WORK_SESSION" and "FINISHED_SESSION" are part way off the bottom of the minibuffer and "CANCELLED_SESSION" does not show up at all.

I use Ivy so I'm not sure if that could be causing a problem.

Does anyone know how to fix this? Is there a way to specify that the minibuffer should expand as much as possible to show all the options?

1
  • I don't use ivy and I don't see the problem you see: the minibuffer expands to accommodate the list above. I expanded it five times by replicating the lists and it still expanded enough to accommodate the larger list. I don't know how to scroll through it if it's bigger than the frame though: there does not seem to be any keybinding that is left for scrolling: all the likely candidates either select a TODO state or do nothing - even C-h selects a TODO state, so I can't ask emacs anything :-) That does seem unfriendly but I would need to dive much deeper to understand what's going on. – NickD Jul 13 at 2:20

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.