0

A few months back my Emacs started to highlight bookmarks. I build and run from master, using the Homebrew emacs-head package. However even after I remove bookmarks, the highlighting remains. I typically use a lot of short lived bookmarks in my code to mark the area I am working on, and the end result is that I end up with lots of lines highlighted even though none of them are bookmarks any longer. I am not using any particular bookmarking packages either, just the regular stuff. I've also deleted all bookmarks from the bookmark list etc, but the highlighting remains in place. Any ideas on how I can clean any buffer with any highlight left overs from previous bookmarks?

5
  • 2
    I'm pissed by this new feature, so I turn it off by setting bookmark-fontify variable to nil. Not that answers your question, but it's what you can do when you are really pissed.
    – TerryTsao
    Commented Jul 19, 2021 at 10:09
  • 1
    Thanks, still helpful. I'd rather have no highlighting than not being able to get rid of highlights. Commented Jul 19, 2021 at 10:11
  • 1
  • 1
    That the highlighting remains after you've deleted all bookmarks sounds like a bug (not that that would be the only problem from this feature having been added as it was). Maybe consider reporting any problems you find with this, using M-x report-emacs-bug (provide a recipe to repro the problem, starting with emacs -Q).
    – Drew
    Commented Jul 19, 2021 at 14:37
  • I've tested with emacs -Q as well, and it has the same behaviour straight out of the box, so reproducing is as simple as setting then trying to get rid of the bookmark highlighted line. Commented Jul 19, 2021 at 15:29

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Browse other questions tagged or ask your own question.