0

One of my major modes defines the keybinding C-M-t, but every time I use it, my operating system (Ubuntu Linux) intercepts the keybinding and opens a terminal.

The OS keybinding overrides the Emacs keybinding. How can I make sure my Emacs keybinding takes precedence over the OS keybinding?

5
  • 4
    No way to do this from Emacs: you got to tell the system to not use the keybinding(s).
    – NickD
    Jul 21 at 2:46
  • 1
    Check if you can change the Meta key in Ubuntu. Otherwise you may want to use the Esc key instead of Meta: Esc-C-t should be bound to transpose-sexps
    – PRouleau
    Jul 22 at 3:54
  • 2
    @NickD: could you please post a (slightly more detailed version of) your comment? That's the answer to the question ("can I do this from within Emacs?"), and we can use this as the canonical post to link to when the question crops up again.
    – Dan
    Jul 22 at 13:53
  • 1
    @Dan - I started an answer and marked it "Community wiki". Let me know what you think. I suppose one avenue of extension would be to indicate how to do it for various DEs, but if you have other ideas, let me know (or edit the answer directly).
    – NickD
    Jul 23 at 18:26
  • 1
    @NickD: looks good. Hopefully other can chip in with specifics for other DEs.
    – Dan
    Jul 23 at 22:11
2

When running emacs under a graphical desktop environment, the DE uses certain keybindings for its own purposes (maximizing/minimizing/moving windows, manipulating desktops, etc.). If you try to use such a keybinding in your emacs, the DE intercepts it, and Emacs will never see it.

If you really, really want to use that keybinding in Emacs, the only way to do it is to convince the DE to not intercept it. How to do that varies by DE, but there is usually some sort of a Settings app, where you can (re)configure such keybindings.

E.g. in my Gnome environment, the Settings app has a Keyboard Shortcuts tab where (some) such things can be configured. Other DEs will have different methods, so YMWV.

0

The solution to my problem was found outside of Emacs.

Using the Settings on Ubuntu I did:

Settings > Keyboard Shortcuts > Launchers > Launch Terminal > Backspace to disable the keyboard shortcut

I hope this will also help me to use less the Ubuntu terminal and use more shell-mode or eshell inside Emacs. I also want to use more Magit instead of using git on Ubuntu's terminal.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.