0

I have trouble installing my environment at work. The only accepted method of authentication for accessing the internet is via kerberos.

My credentials are provided, the server (proxy) with its port is given.

How shall emacs be configured, so that it is able to connect to the internet via kerberos authentication?

I tried setting

(setq url-proxy-services 
  '(("http" . "http://username:pw@proxy:port")
    (" https" . "https://username:pw@proxy:port"))

I also tried omitting the protocol, resulting in: /username:pw@proxy:port.

Also, I created environment variables http_proxy, https_proxy and no_proxy with the same pattern.

I also tried to disable tls1.3, connected via http only (which I really want to avoid) and run the gnutls-cli, which is also not able to athenticate via kerberos with an unknown error.

I am on Windows 10. Available emacs versions are 27.2 and 26.3 (precompiled versions). Installed programs are able to just fallback to my system settings to authenticate at our proxy.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.