1

I am new to doom emacs, I am trying to give a shot to using org mode todos and agenda files. I created a sample org file with a list of to-do items as below.

#+TITLE: Sample list

* Check
** TODO Item 1
** TODO Item 2
** TODO Item 3
** TODO Item 4

After saving this file, when I check the agenda view by doing SPC o a t in doom emacs, I do not see any of these todos listed in there.

Global list of TODO items of type: ALL
Press ‘N r’ (e.g. ‘0 r’) to search again: (0)[ALL]

Below is my config settings relating to org directory.

(setq org-directory "~/notes/")

Can anyone help me with what settings I might be missing here for the agenda view to work properly?

4
  • You need to add the file to your org-agenda-files: not sure of the Doom binding, but in normal Emacs it is C-c [ bound to org-agenda-file-to-front. org-directory does not have any special meaning to Org mode. If you are expecting to add to the agenda list all the files in that directory, read the doc string of the variable org-agenda-files.
    – NickD
    Jul 26 at 20:26
  • I was wrong about org-directory: it does have a special meaning in Org mode, but not the one you seem to be expecting. After you do C-h v org-agenda-files, then do C-h v org-directory to learn more about it.
    – NickD
    Jul 26 at 20:29
  • 1
    Thank you @NickD, I am now able to see the agenda todo items after adding the current file using org-agenda-file-to-front.
    – gowthamr
    Jul 27 at 21:28
  • 1
    Also setting the org-agenda-files to the entire directory lists all TODOs. Thank you !
    – gowthamr
    Jul 27 at 21:34

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.