I'm trying to set up a notification alert for org timer. I'm using Dunst on Arch for notifications.

Used the following lines in my config file:

(require 'org)
(setq org-clock-sound "~/Downloads/ding0.wav")

However, whenever I run org-timer-set-timer, it plays some weird white noise, instead of the file placed in the Downloads folder above.

How can I go about fixing this?

  • AFAICT, this is done by using aplay. So what happens if you run aplay ~/Downloads/ding0.wav from the bash command line?
    – NickD
    Commented Aug 4, 2021 at 13:26
  • Someone was watching David Wilson's video.
    – aadcg
    Commented Aug 5, 2021 at 12:07
  • @NickD I ran aplay ~/Downloads/ding0.wav and it played the same disturbing white noise sound. When I opened the same file with vlc/mpv players, it played just fine.
    – alphaQ
    Commented Aug 5, 2021 at 14:56
  • 1
    @aadcg Haha! SystemCrafters REPRESENT!
    – alphaQ
    Commented Aug 5, 2021 at 14:57
  • 1
    Lol you were right. I think I had just edited the "wav" extension into that file. Downloaded a proper "wav" file now and it works. Thank you so much.
    – alphaQ
    Commented Aug 7, 2021 at 3:45

2 Answers 2


Just to close the loop: the OP had downloaded a file and thought that it was a WAV file, but apparently it was not. OTOH, the Org clock timer uses aplay to play the sound and that can only play WAV files - nothing else. The OP downloaded a "real" WAV file and everything worked properly after that.

(setq org-clock-sound "~/class-is-over.mp3")
(defun my/play-sound (orgin-fn sound)
  (cl-destructuring-bind (_ _ file) sound
    (make-process :name (concat "play-sound-" file)
                  :connection-type 'pipe
                  :command `("afplay" ,file))))
(advice-add 'play-sound :around 'my/play-sound)

advice is your friend. afplay is available on macOS.

  • I am confused: what problem does this solve? AFAICT, the OP resolved the problem by using the correct file: no other change was needed. And why is the advice an around advice? It seems more that you are replacing a command. And afplay seems to be macOS-specific, so this has no chance of working on any other system, correct?
    – NickD
    Commented Jan 28, 2022 at 17:26

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.