0

I am on the process of moving from prelude [1] to a stand-alone config I have created from scratch [2], though by largely copying other people's .emacs. It seems I have inadvertently changed the rendering of the header line in tabulated mode [3], but I am struggling to find out how to configure this correctly. When using prelude, instances of tabulated mode are rendered like so (using doom-dark+ theme):

proced with tabulated mode right rendering

However, in my new .emacs I now get the following:

proced with tabulated mode wrong rendering

It appears I am now "overriding" the rendering of the header line somehow, but I am unsure as to what is causing this. Any pointers would be very helpful.

[1] https://github.com/bbatsov/prelude

[2] https://github.com/mcraveiro/cunene

[3] https://github.com/emacs-mirror/emacs/blob/master/lisp/emacs-lisp/tabulated-list.el

1 Answer 1

0

I haven't completely solved this problem, but I have found more details and a workaround. The gist of it is that doom-themes [1] appear to use the same face for the header-line as they do for the modeline, causing this visual confusion. There are several tickets open on this:

The workaround as per ticket #320 is:

(face-spec-set 'header-line '((t :background "#23214b")))

However, as you can see from the screenshots above, prelude - or my prelude config, not sure just yet - was doing something clever and setting up this face to a more sensible value. I will continue investigating, but this at least makes the theme usable.

[1] https://github.com/hlissner/emacs-doom-themes

Update

Found a much better solution to this problem. On the Emacs with prelude, I did customize-face for face header-line. There you can see all the properties for the face. I then did customize-face for the same face using my new configuration file, and replicated the configuration I had in prelude, and saved it to my custom file. The generated lisp is as follows:

(custom-set-faces
  ;; custom-set-faces was added by Custom.
  ;; If you edit it by hand, you could mess it up, so be careful.
  ;; Your init file should contain only one such instance.
  ;; If there is more than one, they won't work right.
 '(header-line ((t (:inherit mode-line :background "#2b2b2b" :foreground "#f0dfaf" :box (:line-width -1 :color "#585858" :style released-button))))))

I could't quite replicate the grey colour on the border of the box, so #585858 is an approximation. However, the final result is very close:

Header-line with new face

FWIW, the options in custom were as follows:

Custom properties

1

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.