1

I've been successfully using lsp-mode and magit for a while with a light theme (leuven).

Today I was messing with something seemingly unrelated (company-mode and auto-complete settings in my ~/.emacs file) and all of a sudden popups in lsp-mode + company-mode appear as if in a dark theme: enter image description here

The same goes now in magit for the area where the cursor is: enter image description here

Needless to say, it's all unreadable now!

How can I get the light colours back?

My ~/.emacs contents are here, if it helps: https://pastebin.com/Hph4VXvH

Thanks!

3

The problem was this from my ~/.emacs file:

'(frame-background-mode 'dark)
'(hl-sexp-background-color "#1c1f26")

I'm not really sure how it got there, but setting frame-background-mode to nil (so that it will be set according to theme) and commenting the second line did the trick:

 '(frame-background-mode 'nil)
 ;; '(hl-sexp-background-color "#1c1f26")

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.