0

How do I turn off all of the custom faces used by Spacemacs org-mode? For example, the background colouring, the overlines, the bold faces etc.

I tried using the Customize sub-menu from the Org menu to set my own faces, and it added lines like:

'(org-level-1 ((t nil)))

to custom-set-faces in my .dotspacemacs file. However, this doesn't stop Spacemacs showing the top-level heading with a large bold font on a gray background. I find these visual decorations very distracting and just want to see the text that I type!

2 Answers 2

0

If you really want to disable all faces then you should deactivate font-lock-mode by doing M-x font-lock-mode.

You could configure it to happen automatically by adding an org-mode-hook as follows in the user-config section of your dotfile:

(defun my-disable-font-lock ()
  (font-lock-mode 0))

(add-hook 'org-mode-hook 'my-disable-font-lock)
0

Put your cursor on the offending text, then in the top menu, Options->Customize Emacs->Specific Face and you will go directly to the one you want to change.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.