0

Given the following in my org-mode:

**** heading
***** [[https://somewhere.com][somewhere.com]]
***** [[https://somewhereelse.com][somewhereelse.com]]

(which my editor displays as links)

and the following options:

#+OPTIONS: ::t f:nil toc:nil tags:t num:nil author:nil H:11

org-export to text produces:

heading
=======
[somewhere.com] <https://somewhere.com>
* [somewhere.com]
  [somewhere.com] <https://somewhere.com>
* [somewhereelse.com]
  [somewhereelse.com] <https://somewhereelse.com>

There's duplication here which is unexpected and odd because it only happens to the link under the first point. Can anyone explain this to me?

1
  • LaTeX export and HTML export both work properly on this file, so it is very likely a bug in the text exporter only.
    – NickD
    Oct 28 at 13:03
1

Try setting org-ascii-links-to-notes to nil - it is t by default. The doc string of the variable says:

org-ascii-links-to-notes is a variable defined in ‘ox-ascii.el’.

Its value is t

Non-nil means convert links to notes before the next headline. When nil, the link will be exported in place. If the line becomes long in this way, it will be wrapped.

I have to admit I don't really understand its purpose, but I rarely use ascii export and this setting is very much specific to that export engine.

You can use a file-local variable (C-h i g(emacs)File variables) to set it for this file only if you don't want to change it globally. Putting that in a a separate section at the end of the file (it has to be at the end of the file BTW), and marking the section with the noexport tag, is a convenient way to keep this stuff in the file but never see it in the exported document. Something like this:

#+OPTIONS: ::t f:nil toc:nil tags:t num:nil author:nil H:11

* heading
** [[https://somewhere.com][somewhere.com]]
** [[https://somewhereelse.com][somewhereelse.com]]


* Local variables                                       :noexport:

# Local Variables:
# org-ascii-links-to-notes: nil
# End:
1
  • Did you try this? DId it solve your problem?
    – NickD
    Nov 4 at 0:09

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.