1

I'm trying to figure out what to add to my .emacs settings file to get ESS to include an option and setting when sending highlighted code to R. Specifically, I want to set source(max.deparse.length=10000) so that it stops truncating the output (which makes it hard to debug). Can some one please help me.

  • Ubuntu-Mate 20.04
  • GNU Emacs 26.3(build 2, x86_64-pc-linux-gnu, GTK+ Version 3.24.14) of 2020-03-26, modified by Debian
  • ESS version 18.10.2
2
  • Do you run R outside of Emacs? If you only use ESS, you could put that line in your .Rprofile file
    – Tyler
    Commented Nov 17, 2021 at 2:16
  • 1
    Thanks for the suggestion. I do use R from the console some times, but I'm not worried about those situations for now. I have included library(default) and default(source) <- list(max.deparse.length=100000) in my .Rprofile and that seems to work. I'm still curious to know how to do this within ESS and/or if there's a way to set the option without having to use the default library, but that's just because I'm a curious beast. Commented Nov 18, 2021 at 19:34

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Browse other questions tagged or ask your own question.