0

I am relatively new to org mode and, as someone who enjoys writing about music, i decided to try org-babel-lilypond. I use MacOSx Monterey. I have lilypond installed via Macports, as was recommended in this thread. Lilypond seems to work as a command line interface, but when i try to render a lilypond source block in org-mode I'm met with the following error output:

/Applications/lilypond.app/Contents/Resources/bin/lilypond: No such file or directory

Is there a way to configure emacs/org-babel such that it doesn't have to use this directory to render a lilypond block?

1

You have to customize the variable org-babel-lilypond-commands. You can see the variable's doc string with C-h v org-babel-lilypond-commands and you can customize it by clicking on the Customize link in that doc string. You can then set up how to start Lilypond, the PDF viewer and the MIDI player as appropriate for your system. Then hit Apply to set these options for this session. You can try things out and if everything is OK, you can click on Apply and Save to save the settings for future sessions.

1
  • It works wonderfully now. Thank you
    – yvonneb
    Nov 19 at 20:26

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.