0

I am using evil mode.

In org-mode files, when I try to delete a word with dw and the word starts with a \, the last letter of the word is not deleted. For example, if my cursor is on the b of \begin{section} and I type dw I get \n{section} instead of \{section}.

This happens only in org-mode (not in LaTeX or text files), but I can't figure out where in this comes from in my settings. Any idea?

1
  • I can't replicate the problem. Does it still happen if you start emacs without your init file via emacs -Q? If not, you'll need to recursively bisect your init file to isolate the problem.
    – Dan
    Nov 19 '21 at 17:35
0

Found it!

(global-superword-mode 1) is responsible for it.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.