1

I'm currently using DOOM emacs.

I enabled 'centaur-tabs' in ~/.doom.d/init.el by using (tabs +centaur-tabs).

Configures are:

(after! centaur-tabs
  :ensure t                                                                                                                                               
  :config                                                                                                                                                 
   (setq centaur-tabs-style "bar"                                                                                                                          
         centaur-tabs-set-bar 'over                                                                                                                        
         centaur-tabs-height 32                                                                                                                            
         centaur-tabs-set-icons t                                                                                                                          
         centaur-tabs-gray-out-icons 'buffer)                                                                                                              
   (centaur-tabs-headline-match)                                                                                                                           
   (centaur-tabs-mode t))  

However, tabs do not appear over the window.

I already did doctor and sync, and the errors are not shown.

Is there a bug related to using centaur-tabs?

6
  • @phils It's 27.2 Nov 24, 2021 at 10:42
  • @phils It prints out GNU Emacs 27.2 (build 1, x86 64-pc-linux-gnu) of 2021-11-22. Thank you. Nov 24, 2021 at 11:55
  • See ~/.emacs.d/modules/ui/tabs/config.el - it is already configured there. Compare with your code.
    – Ian
    Nov 24, 2021 at 12:15
  • AFAIK tabs ought to work on linux (I believe they don't in Emacs 27 on MacOS, which was the main reason I was interested in the full version string). I'm thinking of tab-bar-mode and tab-line-mode though -- does centaur-tabs just build off those, or is it something entirely different? If the former, do tabs work if you run emacs -Q and enable tab-bar-mode and tab-line-mode?
    – phils
    Nov 24, 2021 at 12:24
  • @phils enabling tab-bar-mode and tab-line-mode make tabs to appear. However, it seems that these tabs are different from centaur-tabs. Nov 24, 2021 at 12:33

1 Answer 1

2

I faced similar problem, adding this line to config.el fixed issue for me (taken from here):

(after! centaur-tabs (centaur-tabs-group-by-projectile-project))

It seems to be a bug of centaur tabs, line above is just a temporary workaround, not a solution. See an issue.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.