0

I was trying to setup elpy with python 3.10 and get the following error:

Elpy Configuration

Emacs.............: 27.2
Elpy..............: Not found (Python), 1.35.0 (Emacs Lisp)
Virtualenv........: venv (/home/carlos/.virtualenvs/venv/)
Interactive Python: python 3.10.0 (/home/carlos/.virtualenvs/venv/bin/python)
RPC virtualenv....: rpc-venv (/home/carlos/.emacs.d/elpy/rpc-venv)
 Python...........: python nil (/home/carlos/.emacs.d/elpy/rpc-venv/bin/python)
 Jedi.............: Not found
 Rope.............: Not found
 Autopep8.........: Not found
 Yapf.............: Not found
 Black............: Not found
Syntax checker....: Not found (flake8)

Warnings

The Python interpreter could not find the elpy module. Please report
to: https://github.com/jorgenschaefer/elpy/issues/new.

There was an unexpected problem starting the RPC process. Please check
the following output to see if this makes sense to you. To me, it
doesn't.

<string>:3: DeprecationWarning: The distutils package is deprecated and slated for removal in Python 3.12. Use setuptools or check PEP 632 for potential alternatives
{"can_connect_to_pypi": true, "rpc_python_version": "3.10.0", "elpy_version": "1.35.0", "jedi_version": null, "jedi_latest": "0.18.1", "rope_version": null, "rope_latest": "0\
.22.0", "autopep8_version": null, "autopep8_latest": "1.6.0", "yapf_version": null, "yapf_latest": "0.31.0", "black_version": null, "black_latest": "21.11b1"}

Elpy could not connect to Pypi (or at least not quickly enough) and
check if the python packages were up-to-date. You can still try to
update all of them:

Basically, the python interpreter cannot find the elpy module, that's why I get Elpy...: Not found (Python). This seems more a problem of python and not elpy and there are multiple issues opened in the elpy repository here, which basically have this problem.

My question is: is there a problem I get Elpy...: Not found? Things seem to be running just fine, so what are the consequences of Python not finding elpy?

Edit: upon a more careful revision I found that Jedi, Rope, etc are not being detected, even though I installed them. I'd image that has to do with the fact the elpy is not found.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.