0

It seems elpy doesn't work with python 3.10. For instance, see the issue here posted on the elpy repo in github. I had the same problem as that person mentions, and it seems many other people too when going to the issues in the official repo.

Does anyone know if somebody is working on fixing this issue? If so, an estimate of when it will be solved?

P.D. if this question does not belong here, I'll delete it.

6
  • 1
    Off-topic: Free software is maintained by volunteers and enthusiasts. Within this mindset, everyone is encouraged to develop and fix their own tools. In short, it's impossible to estimate such a thing.
    – aadcg
    Nov 25 at 20:53
  • 1
    Yes, I know. And I appreciate the effort of those people. While it is impossible to estimate, maybe someone here has insider information.
    – Schach21
    Nov 25 at 21:11
  • 1
    AFAIK, elpy's author is no longer involved in the project. It is now maintained by volunteers.
    – aadcg
    Nov 25 at 22:53
  • You should open an issue on the elpy github site or upvote an existing issue. You can also add a "me too" comment on an existing issue. This is not the proper forum for your question.
    – NickD
    Nov 25 at 23:28
  • 1
    It would be wise to look for an alternate solution to Elpy (the actual maintainer is not able to maintain it, see the main page on github, on provided link) so look for Language server Protocol for Emacs emacs-lsp.github.io/lsp-mode and the pylspserver emacs-lsp.github.io/lsp-mode/page/lsp-pylsp.
    – Ian
    Nov 26 at 7:48

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.