3

I have GNU Emacs 27.2 (of 2021-11-18; on macOS 12.1) and updated dired+.el from dired+ just now (to fix a bug, so I can't go back to the old version of dired+.el I had). Before the update, dired-mode looked like this:

enter image description here

After the update, dired-mode looks like that:

enter image description here

I'd like to have the "long" format back. Specifying (setq dired-listing-switches "ls -lh --time-style=long-iso") doesn't seem to affect the problem. How can I force a certain format with dired+?

Note that the original dired+.el which did not show this problem was version 21.2 (last updated 2013-01-28) and the current version is 2021.10.03 (last updated 2021-12-11).

Update

... just found that I can toggle the view with ( (a change since Emacs 24 or so). The problems is also mentioned here and here. Neither solutions directly worked but setting

(setq diredp-hide-details-initially-flag nil)
(setq diredp-hide-details-propagate-flag nil)

after (require 'dired+) seems to work (any side-effects/better approach?)

3
  • Did you look at the variable dired-listing-switches?
    – aadcg
    Jan 10 at 17:32
  • Hi, thanks, yes, that shows -al as it should. Jan 10 at 17:42
  • Oops, sorry, didn't read your question carefully.
    – aadcg
    Jan 10 at 19:16

1 Answer 1

4

You might want to edit your question, because it starts out saying one thing, suggesting that it's about ls changes, and ends up (correctly) saying another thing, which is that by default Dired+ hides details.

Anyway, the answer to your question is what you discovered just this:

(setq diredp-hide-details-initially-flag nil)

(But as a general rule it's better to use M-x customize-option or customize-set-variable than to use setq. In this case it doesn't matter.)

You don't need to change option diredp-hide-details-propagate-flag for your question. That's something different. That's about whether you want the subsequent (new) Dired buffers to use the same detail-hide/show behavior as the last one.


BTW, the beginning of your question kind of threw me off, as I was mistakenly getting the impression that you updated from a fairly recent version of Dired+. In fact, you must have updated from a very old version.

Also, just ( is enough to toggle hiding details. M-x ( doesn't do that. (There's no command (, at least not in Dired+.)

2
  • Thanks for your help, Drew, also for updating my post. Jan 11 at 13:53
  • Just to add: The one-line solution that Drew provided only worked for me if it was put before (require 'dired+) (otherwise only the two-line solution in my Update worked). Jan 11 at 15:16

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.