1

I've noticed that for some themes, different windows have different background colors. I suspect this has to do with the major mode of the window, but I'm not sure. Here's an example of what I'm talking about:

enter image description here

Looking at the faces, they both seem to have the same background color set. For the window on the right, counsel-faces shows that the cursor is under the default face which has the following configuration

Face: default (sample) (customize this face)

Documentation:
Basic default face.

Defined in ‘faces.el’.


        Family: Source Code Pro
        Foundry: ADBO
            Width: normal
        Height: 99
        Weight: normal
            Slant: normal
    Foreground: #000000
DistantForeground: unspecified
    Background: #ffffff
        Underline: nil
        Overline: nil
Strike-through: nil
            Box: nil
        Inverse: nil
        Stipple: nil
            Font: #<font-object -ADBO-Source Code Pro-normal-normal-normal-*-13-*-*-*-m-0-iso10646-1>
        Fontset: -ADBO-Source Code Pro-normal-normal-normal-*-13-*-*-*-m-0-fontset-startup
        Extend: nil
        Inherit: nil

Using counsel-face on the window on the left also suggests the cursor is under the default face. Again, the background is specified as #ffffff, however clearly that is not what is displayed.

I'm using the modus-operandi theme it it's relevant, however this different color background behavior is present across multiple (though not all) themes. Anyone know why Doom Emacs might have different background colors for different windows?

5
  • 1
    Are you by any chance using a minor mode such as dimmer-mode?
    – d125q
    Feb 7 at 9:54
  • Please state the question clearly, including in the title. Please state it specifically, not something as general as "Anyone know what might be going on here?"
    – Drew
    Feb 7 at 16:42
  • @Drew I edited it per your comments. Feb 7 at 17:16
  • @d125q It wasn't dimmer-mode but thanks to your comment I was able to find the issue. Apparently another minor mode called Solaire causes this issue. I turned it off and now I get the behavior I expect. Thank you! If you'd like to turn your comment into an answer, I'd upvote and checkmark it. Feb 7 at 17:19
  • @Dargscisyhp — Happy to have helped find the culprit; I think you should post your own answer instead, as solaire-mode seems to be built into Doom Emacs.
    – d125q
    Feb 8 at 9:12

1 Answer 1

1

As part of the ui/doom module, there is a package called solaire-mode. This causes file-visiting buffers to stand out compared to other buffers, and is what caused two different background colors in the picture I posted in my question. According to the manual, the solaire package can be removed by going to your packages.el file and adding.

(package! solaire-mode :disable t)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.