0

when using C-c C-q to run org-set-tags-command on an existing headline, i am unable to see the list of tags because the buffer window is so small. all i see is inherited tags and current tags lines.

the seq_todo states view is fine, invoked with C-c C-t

i do not see a way to resize that buffer nor any clue why this happening

how can i expand the size of the tag selection window/buffer so that all tag choices are visible?

here is a screenshot of what i am seeing enter image description here

6
  • Click-and-hold and drag on the modeline of the window above to expand the window - assuming you are using GUI Emacs. OTOH, the window is big enough to show all my choices: how many tags do you have in the completion list?
    – NickD
    Mar 9, 2022 at 5:01
  • @NickD modeline drag is disabled when the " *Org tags*" buffer comes up. i am using gui emacs. there's only 5 tags
    – tbny
    Mar 9, 2022 at 5:43
  • I thought you were talking about tag completion. You are talking about "fast tag selection", correct? The *Org tags* buffer is indeed inactive: only the fast tag selection keys are active, but in my case, it's big enough (I added 24 tags and the buffer kept expanding to accommodate them). Not sure why you are having a problem. What version of Org mode are you using (just in case there is a bug in that version)?
    – NickD
    Mar 9, 2022 at 6:05
  • @NickD was not sure how to communicate which buffer was having the issue. added a screenshot to the post. i am using w.e. version of org-mode that ships with emacs 27.2
    – tbny
    Mar 9, 2022 at 6:18
  • 1
    @NickD the overlay is just org-modern, disabling it doesn't fix the issue. starting emacs with the quick option did fix the issue, so there must be some other customization happening that causes the view to be too small. gonna try to step through stuff one at a time
    – tbny
    Mar 9, 2022 at 7:01

1 Answer 1

1

someone pointed out in the comments to start emacs with the --quick option and that helped debug the issue. didn't take long to go through a few config options one by one. found the issue is a modeline customization i have setup through the doom-modeline package. disabling the modeline shows the correct view when using fast-set-tags buffer

the issue is mitigated with customizing doom-modeline height, but it can only go so small and the view still gets clipped.

(custom-set-variables
  `(doom-modeline-height 15))

another temporary work around is to re-bind C-c C-q to a lambda that disables doom-modeline before operations, and re-enables doom-modeline after operations. this works better imo, but i am unable to figure out why doom-modeline-mode is not re-enabled if the fast-set-tags buffer is quit with q (tried following the source code, no errors raised, nothing thrown [org.el, etags.el, window.el])

(define-key org-mode-map (kbd "C-c C-q")
  (lambda (&optional arg)
    (interactive "P")
    (doom-modeline-mode -1)
    (org-set-tags-command arg)
    (doom-modeline-mode 1)))

doom-modeline github mentions this issue as [Bug] Clipped org mode tag menu, the bug is marked resolved, but the tags display issue persists

UPDATE:

a better work around proposed by doom-modeline devs is adding advice

(advice-add #'fit-window-to-buffer :before (lambda (&rest _) (redisplay t)))

this issue will be resolved with future emacs releases

2
  • I'd suggest that you add a comment to issue #291, add a link to this question and request that it be reopened.
    – NickD
    Mar 9, 2022 at 11:53
  • @NickD good idea, and thank you!
    – tbny
    Mar 9, 2022 at 19:45

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.