1

while I am using Emacs as an editor for years on my Macbook (OSX 10.13), I only recently started again to launch external commands by using Gnus. While this answer helped me to fix calls to uncompface, it is still failing for w3m:

Cannot open load file: No such file or directory, w3m

Actually in the *Messages* buffer I see

mm-setup-w3m: Cannot open load file: No such file or directory, w3m
  • both uncompface and w3m are installed using brew in /usr/local/bin
  • my $PATH is defined in ~/.bash_profile
  • and it was also defined for graphical apps with sudo launchctl config user path $PATH
  • if I check in Emacs with getenv, the path does contain /usr/local/bin

What am I missing?

I remember before finishing with 10.13 (my MacBook is now unsupported by Apple) that configuring $PATH for apps is a periodic pain in the *ss, I previously used a .plist for launchd that is now unsupported.

1 Answer 1

2

What you installed is the package that contains the command-line tool w3m. But you also need the package that implements the Emacs interface to (the command-line tool) w3m.

This package is also commonly called w3m, which might explain the confusion. The Emacs package can be found on MELPA, so assuming you have MELPA as one of your package sources, you should be able to say M-x package-install RET w3m RET and you should be all set.

If for whatever reason you can't use the Emacs package system, you can install it by hand. See the Emacs Wiki here and here for an explanation and details on how to get it.

EDIT: Check the value of package-archives - I see the package in melpa-unstable, so you need an entry like ("melpa-unstable" . "http://melpa.org/packages/") in it, and then do M-x package-refresh.

EDIT: The OP reports that the package was found in the "normal" MELPA archive, so the previous EDIT can be partially disregarded.

3
  • Thanks for your answer. While I did not installed many packages I do have melpa configured package-archives is set to (("gnu" . "https://elpa.gnu.org/packages/") ("melpa-stable" . "http://stable.melpa.org/packages/")) I do not see w3m in the available packages. Investigation is still pending.
    – Seki
    Commented Mar 15, 2022 at 10:12
  • I think you need melpa-unstable: I updated the answer.
    – NickD
    Commented Mar 15, 2022 at 13:33
  • Without switching to unstable, using the "normal" melpa repo did the trick. I used this answer to setup a ponderated multi repo-setup. Thanks!
    – Seki
    Commented Mar 15, 2022 at 17:45

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.