0

I'm just getting started with emacs, and I'm trying to enable org-superstar-mode automatically upon launching an org file. I've installed org-superstar, and I can run M-x org-superstar-mode when in an org file to set it manually. However, I have the following in my .emacs:

(use-package org-superstar
  :config
  (setq org-superstar-special-todo-items t)
  (add-hook 'org-mode-hook (lambda ()
                             (org-superstar-mode 1))))

and my org files still do not load org-superstar-mode by default, need to do it manually. Am I misunderstanding the purpose of 'org-superstar-mode 1'? Or have I made an error?

EDIT: I'm not sure what exactly was going wrong, but I ended up just cleaning out my .emacs file and starting from scratch. Cheers.

2 Answers 2

1

Are you setting use-package-always-defer to t, If that the config code won't be executed. Try:

(use-package org-superstar
  :after org
  :hook (org-mode . org-superstar-mode)
  :config
  (setq org-superstar-special-todo-items t))

or

(use-package org-superstar
  :init
  (add-hook 'org-mode-hook #'org-superstar-mode)
  :config
  (setq org-superstar-special-todo-items t))
1
  • No luck with either of those, and no I am not setting use-package-always-defer
    – ChasingUG
    Mar 21, 2022 at 17:20
0

I ended up just cleaning out my .emacs folder, undownloading everything from melpa, and starting from scratch. Kept a close eye on git documentation instructions, and proceeded with care. Good luck everyone.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.