0

So my org-agenda was working perfectly in Spacemacs 0.990.0 on emacs 27.1 on Ubuntu 18.04 LTS. But I upgraded to Ubuntu 20.04 LTS, and updated all of my Emacs and Spacemacs packages, including org-mode and org-gcal, etc. Now org-agenda is not showing anything. This is kinda a hard question to ask, but I am not sure how to debug this problem.

Here is a picture of what my agenda looks like now--just blank. enter image description here

In checking the *Messages* buffer, I noticed a couple of issues. The main thing seems to be that the org-agenda discovery mechanism is not finding any tasks in the org files. Here is the specific message below.

Finding :entry-id: locations (144/145 files): /xxx/journal_p_oss_juliadiffeq.org
Finding :entry-id: locations (145/145 files): /xxx/agenda_p_oss_juliadiffeq.org
145 files scanned, 0 files contain IDs, and 0 :entry-id: IDs found.

Finally, the message buffer says that it fetched org-gcal entries into the gcal.org file--but I checked and there are no entries in the gcal.org file - the gcal.org file is completely empty. So org-gcal does not seem to be working.

Events fetched into
~/xxx/gcal.org
Completed event fetching .
Events fetched into
~/xxx/gcal.org
Finding :entry-id: locations (1/145 files): /xxx/blog.org

Could anyone suggest any additional debugging steps or how to solve this? Or is there any additional information that I can provide?

5
  • Please don't use images: Org mode files and Emacs error messages are just text. You can cut and paste text into markdown source blocks much more easily than saving screen shots and they are much more readable and can also be cut-and-pasted (e.g. to search for error messages in the Emacs/Org mode source files). Images are sometimes unavoidable, but more often than not, they are a pain (e.g. the first image here is OK, but the other two should be text blocks).
    – NickD
    Commented Mar 27, 2022 at 20:13
  • Even the first image is unnecessary: saying you got an empty agenda is enough.
    – NickD
    Commented Mar 27, 2022 at 20:24
  • @NickD should I replace the images with the text instead? I thought the image might be helpful since sometimes I am not sure what is relevant--meaning that sometimes the formatting of the messages might give some clues--but I might omit some of that formatting when simply copying the text. That was just my idea, but I could replace the images if that helps.
    – krishnab
    Commented Mar 27, 2022 at 20:27
  • If you copy the text accurately, then it is much more helpful than the images. But don't type it in: that way, mistakes creep in; cut-and-paste it instead within markdown code block delimiters.
    – NickD
    Commented Mar 27, 2022 at 20:39
  • 1
    @NickDokay, I swapped out the images for the text messages. Hope this helps.
    – krishnab
    Commented Mar 27, 2022 at 20:58

1 Answer 1

0

Okay, this is not the best answer, but it worked. The solution was that I went into the ~/.emacs.d/elpa folder, and I deleted the org-mode folder. Then I restarted emacs, and Spacemacs proceeded to download org-mode again. So that was good. Then I tried to load the agenda, and after a few times of trying and killing the agenda, it worked. So that is the answer. Try to delete the org folder, then let it reinstall, and then try to get the agenda again.

2
  • Sometimes, things are so hopeless that reinstalling is about the only solution. Still, it would have been interesting to see how hopeless things were, by debugging a bit. Ah, well...
    – NickD
    Commented Mar 28, 2022 at 0:46
  • @NickD yes true. I would have liked to have got to the bottom of it. I have a sense that it was org-gcal that was somehow getting locked or staying locked. And so that was somehow subverting the agenda from displaying. It was as if the agenda was just waiting for org-gcal to unlock or something. I also think that perhaps some of the compiled .elc files in the org folder might have had stale information. But I can't prove it one way or the other.
    – krishnab
    Commented Mar 28, 2022 at 3:24

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.