4

I'm not entirely sure what the problem is. I'm using the same version of Emacs on three different computers ( laptop, work, home ), and the problem only shows up on one machine ( the home machine ).

Basically, when I'm using Emacs ( 24.4, compiled from downloaded tar.gz ) Emacs seems to take quite a while to do any sort of vertical rendering. Scrolling, finding a file ( using a custom ido vertical mode ), helm... anything that requires Emacs to render vertically seems to slow down Emacs.

It doesn't seem to have to do anything with how many lines are in the current buffer, the slow-down happens even in the scratch buffer.

I've also tried starting with emacs -Q, and it still happens.

Oddly, it's CPU/memory usage stays pretty low while this rendering is happening.

I took a video of the weirdness, just in case my description wasn't super clear.

  • Did you have GTK3 installed? You should compile it with this option --with-x-toolkit=gtk3. – Tu Do Jan 8 '15 at 6:45
  • I've tried with GTK3 and without, it's the same either way. The only thing that seems to make any difference was disabling xft. I'm trying again with only --without-xft --without-m17n-flt --without-selinux as options. – Sean Hagen Jan 8 '15 at 6:54
  • Even with --without-xft, the rendering is still slow. – Sean Hagen Jan 8 '15 at 7:06
  • Just downloaded 25.0.50.1 from git, and it's facing the same issue. So... maybe this is an issue with one of the libraries that Emacs is using, and not Emacs itself? Any idea how I could track down what's taking the rendering so long? – Sean Hagen Jan 8 '15 at 7:32
  • What is your OS? Maybe could try it with another window system? Meanwhile, you can use Emacs in terminal while investigating this issue. – Tu Do Jan 8 '15 at 9:03
2

So I finally restarted my computer, and tried running Emacs with the Unity WM. It ran fine, so I logged out and tried it again in ratpoison. Ran fine.

No idea what the problem was, or what the solution was. Just commenting to prevent people from wondering what happened.

  • Although it comes back randomly when I restart/shutdown+startup. This is super annoying. – Sean Hagen Feb 11 '15 at 19:24
1

I had this problem with emacs 24.3 on xubuntu running xfce 4.10, even for completely trivial text files It only appeared in the "xemacs" (gtk) version, it ran fine in a command shell with the DISPLAY env var unset. I used the xfce Settings / Window Manager Tweaks dialog to switch display compositing ON and that fixed it!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.