2

I tried to configure org-publish with some html variables, but I'm getting this error let: Wrong number of arguments: plist-get, 3. I've debug-on-error enabled but doesn't show up the minibuffer.

This is my config .el file.

(require 'ox-publish)
(require 'ox-rss)


;; Initial configuration
(setq project-source "~/org/blog/"
      project-dest   "~/org/public/"
      website-url    "blog.me")


(setq blog-head
  "<link rel=\"stylesheet\" href=\"css/site.css\" type=\"text/css\">")


(setq blog-preamble
  "<div class=\"nav\"><ul>
  <li><a href=\"/\">Home</a></li>
  <li><a href=\"/blog/index.html\">Blog</a></li>
  <li><a href=\"http://github.com/NicolasPetton\">GitHub</a></li>
  <li><a href=\"http://twitter.com/NicolasPetton\">Twitter</a></li>
  <li><a href=\"/contact.html\">Contact</a></li>
  </ul></div>")


(setq org-publish-project-alist
      `(("org"
         :base-directory "~/org/blog/"
         :base-extension "org"
         :publishing-directory "~/org/public/"
         :publishing-function org-html-publish-to-html
         :section-numbers nil
         :with-toc nil
         :html-head-extra ,blog-head
         :html-preamble ,blog-preamble)
        
        ("posts"
         :base-directory "~/org/blog/posts/"
         :base-extension "org"
         :publishing-directory "~/org/public/posts/"
         :publishing-function org-html-publish-to-html
         :section-numbers nil
         :with-toc nil
         :html-preamble ,blog-preamble)

        ("images"
         :base-directory "~/org/blog/images/"
         :base-extension "jpg\\|gif\\|png"
         :publishing-directory "~/org/public/images/"
         :publishing-function org-publish-attachment)

        ("js"
         :base-directory "~/org/blog/js/"
         :base-extension "js"
         :publishing-directory "~/org/public/js/"
         :publishing-function org-publish-attachment)

        ("css"
         :base-directory "~/org/blog/css/"
         :base-extension "css"
         :publishing-directory "~/org/public/css/"
         :publishing-function org-publish-attachment)

        ("rss"
         :base-directory "~/org/blog/"
         :base-extension "org"
         :publishing-directory "~/org/public/"
         :publishing-function (org-rss-publish-to-rss)
         :html-link-home "http://blog.me"
         :html-link-use-abs-url t)

        ("blog" :components ("org" "posts" "images" "js" "css" "rss"))))

backtrace

Resetting org-publish-cache
Loading /Users/elia/.emacs.d/.local/cache/org-timestamps/org.cache...done
Publishing file /Users/elia/org/blog/blog-setup.org using ‘org-html-publish-to-html’
Note: sgml-basic-offset, tab-width adjusted to 2
Saving file /Users/elia/org/public/blog-setup.html...
Wrote /Users/elia/org/public/blog-setup.html
Resetting org-publish-cache
Loading /Users/elia/.emacs.d/.local/cache/org-timestamps/posts.cache...done
Resetting org-publish-cache
Loading /Users/elia/.emacs.d/.local/cache/org-timestamps/images.cache...done
Resetting org-publish-cache
Loading /Users/elia/.emacs.d/.local/cache/org-timestamps/js.cache...done
Resetting org-publish-cache
Loading /Users/elia/.emacs.d/.local/cache/org-timestamps/css.cache...done
Skipping unmodified file /Users/elia/org/blog/css/styles.css
Resetting org-publish-cache
Loading /Users/elia/.emacs.d/.local/cache/org-timestamps/rss.cache...done
Publishing file /Users/elia/org/blog/blog-setup.org using ‘org-rss-publish-to-rss’
Saving file /Users/elia/org/blog/blog-setup.org...
Wrote /Users/elia/org/blog/blog-setup.org
let: Wrong number of arguments: plist-get, 3

so yes is ox-rss the problem. I'm using this ox-rss.el locally

4
  • Show a backtrace, with the complete error msg and some of the call stack. You don't show any code that contains let of plist-get.
    – Drew
    May 16 at 1:47
  • The rss publishing function looks suspect: the parentheses are probably wrong. Whether that's what's behind the error is unknown: you need to give us a backtrace as @Drew requested. Making sure that debug-on-error is t and running org-publish should be enough for that. If you don't get a backtrace, try M-x top-level before checking the variable and re-running org-publish - or start with a fresh session of Emacs.
    – NickD
    May 16 at 2:13
  • 1
    That's not a backtrace: it's just the output. Moreover, there is no indication that I can see that ox-rss is the problem from the output you show. Did you have to get rid of the parentheses around org-rss-publish-to-rss? As it stands, the question is incomplete and possibly misleading. Please fix it.
    – NickD
    May 16 at 12:18
  • What @NickD said. Please post the backtrace you get from debug-on-error.
    – Drew
    May 16 at 14:53

1 Answer 1

0

Solved by installing org-contrib via elpa.

2
  • 1
    Please use the edit link on your question to add additional information. The Post Answer button should be used only for complete answers to the question. - From Review
    – NickD
    May 16 at 12:19
  • Installing org-contrib instead of using ox-rss.el file taken from the source, solved the problem. So I would consider it a valid answer to my issue
    – Ganjalf
    May 20 at 8:22

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.