since some time I have encountered a problem with opening pdf links with pdf-tools. I am using doom-emacs and have just the line

(add-to-list 'org-file-apps '("\\.pdf\\'" . org-pdfview-open))

to select the viewer in my config. Previously all worked well. Now for some reason I can open pdfs with counsel-find-file or other commands. But if I press enter on a pdf link I get

Symbol’s function definition is void: org-pdfview-open

I know it's hard to determine the error source without seeing everything in detail, but what could it be?

1 Answer 1


The error message says that symbol org-pdfview-open does not point to a function. This, and the fact that piece of configuration used to work, means that the function definition disappeared from your system.

Not sure how that happened exactly: I don't think org-pdfview was in the core of a previous version of Emacs (thus, could've disappeared because of an update). Perhaps you were moving code around, or changed the configuration of your load-path so that the code can't be loaded anymore.

Note, however, that in the org-pdfview's repository the package is indicated as not maintained anymore. It also points to a fork called org-pdftools (which I see available on Melpa).

If you want to proceed using this one, it seems you'll have to use the function org-pdftools-open instead of org-pdfview-open.

I hope this helps

  • At least I am somewhat further with my problem. When I try to use (add-to-list 'org-file-apps '("\\.pdf\\'" . org-pdftools-open)) I get a new error message I am not able to interpret: user-error: Please see Org News for version 9.0 about ‘org-file-apps’--Lisp error: org-pdftools-open.
    – Rareform
    Jun 15, 2022 at 14:11
  • Seems like this orgmode.org/worg/org-release-notes.html#org59828f4 ? Jun 15, 2022 at 14:41
  • This seems to be saying that the function, as of Org 9.0, must accept two arguments, a file and a link, but org-pdftools-open only accepts a file. Maybe you can define your own function that takes the extra link arg, and ignores it and just calls org-pdftools-open with the file... but I don't understand the details enough to know if that would work. Jun 15, 2022 at 14:47
  • Please don't ask a question in a comment. If the answer has helped, upvote it, even if it has not solved the problem (if it has solved the problem, you should accept it of course). Then ask a new question for org-pdftools. Questions or answers in comments are not useful: you cannot search for them (and search is difficult enough even without that complication).
    – NickD
    Jun 15, 2022 at 15:16

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.